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Welcome to Analyze 9.0, a robust, powerful, and practical research software for advanced biomedical imaging 
visualization, manipulation, and measurement.  Analyze features integrated, complementary tools for fully 
interactive multi-dimensional display, processing, segmentation, registration, and measurement of biomedical 
imaging modalities including MRI, CT, PET, SPECT, ultrasound, and digital microscopy.  It has been designed 
and carefully programmed to be highly efficient and user-interactive, performing powerful 3-D image processing 
and display operations in seconds.  The applications of Analyze are broad in scope, wide in scale, and 
penetrating in impact.  
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Before installing Analyze 9.0, it is recommended to uninstall any previous Analyze versions resident on your 
system. Otherwise, make sure to choose a new directory for Analyze 9.0 during installation. To uninstall 
previous versions of Analyze:

Open the Windows 1.	 Control Panel (Start > Control Panel) and select Add or Remove Programs.

In the window returned, click 2.	 Change or Remove Programs.

Select the previous version of Analyze and click 3.	 Remove. A dialog box will be returned requesting 
confirmation, click Yes. The previous version of Analyze will now be removed from your system.

Navigate to your 4.	 C: drive and delete the C:\BIR folder.

Analyze 9.0 requires the following minimum PC configuration:

Windows XP or Vista (32- or 64-bit)•	
Intel Core or comparable processor•	
Network card•	
CD-ROM drive•	
512 MB RAM*•	
24/32-Bit graphics capability•	
At least 450 MB disk space•	

*Analyze requires RAM equal to twice the size of the data set being processed (e.g. a 256 MB data set 
requires at least 512 MB of RAM).

The InstallShield Wizard program will lead you through the complete Analyze 9.0 installation process 
(including optional components, such as the AVW Developers Add-On). To begin the installation process:

It is recommended to close all active programs on your desktop.1.	

Insert the 2.	 Analyze 9.0 Installation CD into your computer. 

Once the Installation CD is inserted, the3.	  InstallShield Wizard for Analyze 9.0 should automatically open.

Note – If you choose not to uninstall your previous version of Analyze, you will need to create a new folder on your 
C: drive named BIR9 before proceeding. During Analyze 9.0 installation, set the ‘Destination Folder’ to this new 
C:\BIR9 folder by clicking the ‘Change’ button.

If the InstallShield Wizard does not run automatically, open a Windows Explorer window and navigate to the ‘My 
Computer’ location. Locate the CD drive that shows ‘Analyze_9.0’ and select ‘Auto Play’.
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The InstallShield Wizard opens to a ‘Welcome’ screen. Click 4.	 Next to begin the Analyze 9.0 installation.

License Agreement:5.	  Please read the End-User License Agreement for AnalyzeDirect Software and select 
‘I accept’ or ‘I do not accept’. Note – If you select ‘I do not accept’, Analyze will not be installed. Click Next.

Destination Folder6.	 : The default location for installation is C:\BIR (when Windows is installed on the 
C: drive); it is recommended to leave this as the destination folder. Click Next.

‘BIR’ stands for Biomedical Imaging Resource, the organization at Mayo Clinic that develops Analyze.
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Setup Type:7.	  You may choose from the following setup types:

Setup Type Required Disk Space
Analyze with Tutorials (Typical) – Installs Analyze 9.0, the Analyze 

Tutorials, and ITK Extension* 173	 MB

Analyze Only (Minimum) – Only installs Analyze 9.0 125	 MB

Customized Analyze (Custom) – Installs Analyze 9.0 and permits 
selection of six optional components on the next screen:

AVW Developers Kit-- 60	 MB
AVW Examples in C and TCL-- 536	 KB
Data for AVW Examples-- 16	 MB
Analyze Tutorials-- 41	 MB
ITK Runtime Extension -- 6.7	 MB
ITK Developers Kit-- 944	 KB

For most users, it is recommended to choose the 8.	 Analyze with Tutorials (Typical) setup type. 

If you plan to use the Analyze Developers Add-On, 
choose the Customized Analyze (Custom) setup type 
and click Next. The screen that follows will allow you 
to deselect any components you do NOT wish to install 
before proceeding with installation.

Once you have selected your setup type, click Next.

*The ITK Extension component installs additional filtering, segmentation, and registration modules in Analyze 
that have been developed with functions from the ITK Library.

The Analyze Developers Add-On requires a special license 
file. To learn more about this Add-On, and to find out if your 
license file provides access, please refer to the Analyze 
Developers Add-On section at the end of this document.  
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Ready to Install the Program:9.	  Verify that the ‘Current Settings’ are accurate, then click Install.

Analyze 9.0 10.	 will now be installed in the C:\BIR directory. During installation, an Analyze 9.0 
shortcut icon will be placed on your Desktop.  A Mayo Clinic Analyze folder will also be added 
to the Windows Start > All Programs menu.

When the InstallShield Wizard notifies you that installation is complete, click 11.	 Finish.  

A dialog box will immediately open, stating that 12.	 an AnalyzeDirect.lic license file must be installed to run 
Analyze 9.0. Instead of clicking ‘Yes’ to go to the AnalyzeDirect website - www.analyzedirect.com - click 
No and follow the instructions in the next section of this document, “Analyze License Files”. 

http://www.analyzedirect.com
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A system-specific license file must be installed before Analyze 9.0 will run. You can obtain this license 
file from AnalyzeDirect. 

In order to generate your license file, AnalyzeDirect must receive two pieces of information specific to your 
computer: 1) the Host Name and 2) the System ID.  The instructions below will explain how to find this 
information, and how to send it to AnalyzeDirect.

Go to the Windows 1.	 Start menu and select All Programs > Mayo Clinic Analyze > BIRlic Tool.

The 2.	 BIRlic Tool will open to the System Info tab.

Please take a 3.	 screenshot* of the System Info tab. Send this screenshot, along with your name, 
company/institution, and telephone number to validate@analyzedirect.com.

Once AnalyzeDirect receives your system information, an 4.	 AnalyzeDirect.lic license file will be 
generated and sent to you via e-mail.  

To install this AnalyzeDirect.lic license file, please refer to the instructions for your license type (node-5.	
locked or floating) found under the section entitled “License File Installation”.

*To take a screenshot press <Alt+Print Screen> on your keyboard. A screenshot of the current active window will be 
saved to memory. Paste the screenshot into your e-mail or into a Word document that you send as an attachment.

If the BIRlic Tool fails to open, please contact the AnalyzeDirect Support Team at support@analyzedirect.com.

Note – All 30-day evaluation license files are node-locked licenses.
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Analyze 9.0 uses the BIRlic license management system for Analyze validation and runtime license 
administration. The BIRlic license management software can be found in the C:\BIR\BIRlic-9.0 directory. 
BIRlic administers two types of Analyze licenses – node-locked and counted floating licenses.

A node-locked license will allow Analyze 9.0 to be run on one system only.  With a node-locked license, 
all license file administration is handled local to the specific system.  Additionally, on Windows systems the 
BIRlic license manager does not need to be configured for a node-locked license.

A floating license allows one system to act as a license server, “floating” the license across a network 
to a client system. Any client system with access to the license server can check out a license if one is 
available. Note – if only one floating license is purchased, two or more client system cannot run Analyze 
simultaneously.

For information on license pricing and options, please contact sales@analyzedirect.com.  

Your AnalyzeDirect.lic license file will be stored in the C:\BIR\BIRlic-9.0\Licenses directory. Note – during 
Analyze 9.0 installation, a default AnalyzeDirect.lic license file is placed in this Licenses directory.

The default AnalyzeDirect.lic license file MUST BE REPLACED by a system-specific license file, 
otherwise Analyze 9.0 will not run!

Once you receive your system-specific AnalyzeDirect.lic license file, it must be installed before Analyze 9.0 
will run. Instructions for installing a node-locked license can be found immediately below. If you purchased 
a dongle for your node-locked license, please refer to the “Dongle Installation” section at the end of this 
document. Instructions for installing a floating license are located on the proceeding page. If you are unsure 
what type of license you have, or encounter any difficulties with license file installation, please contact 
support@analyzedirect.com.

Installing an AnalyzeDirect.lic Node-Locked License

Locate the 1.	 AnalyzeDirect.lic license file sent to you via e-mail. 

Save this 2.	 AnalyzeDirect.lic file in the C:\BIR\BIRlic-9.0\Licenses directory.  

Click 3.	 Yes when asked if you would like to replace the existing ‘AnalyzeDirect.lic’. 

No further configuration is needed for a node-locked license on a Windows system. To run Analyze 4.	
9.0, please refer to the section entitled “Running Analyze 9.0”.

Windows users can also purchase a dongle as an add-on to their node-locked license. A dongle is a USB device 
that allows you to easily move the license between different Windows computers.

Note – All 30-day evaluation license files are node-locked licenses.

mailto:sales@analyzedirect.com
mailto:support@analyzedirect.com
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Installing an AnalyzeDirect.lic Floating License – Server System Configuration

A floating license requires that the BIRlic license server be running on the system that will act as the 
license server. Complete the following steps to configure the license server system:

Locate the 1.	 AnalyzeDirect.lic license file sent to you via e-mail. 

Save this 2.	 AnalyzeDirect.lic file in the C:\BIR\BIRlic-9.0\Licenses directory.  

Click 3.	 Yes when asked if you would like to replace the existing ‘AnalyzeDirect.lic’. 

Open the 4.	 BIRlic Tool (Start > All Programs > Mayo Clinic Analyze > BIRlic Tool).

Select the 5.	 Server tab.

Click 6.	 Install Service [A] to install the BIRlic license server as a Windows Service that will 
automatically start the license server at system boot. Click Yes when asked to confirm the installing 
‘BIRlic Server as a Service’ on this computer.

Once the Service has been installed, a notification window will open. Click 7.	 OK.  

Click 8.	 Start Service [B] to start the license server service. Click Yes when asked to confirm starting 
‘BIRlic Server as a Service’ on this computer.

Once the Service has been started, a notification window will appear. Click 9.	 OK.

To start the server process, you can restart your system or click 10.	 Start Server [C]. Click Yes when 
asked to confirm starting a ‘local License Server’ on this computer.

The BIRlic license server configuration is now complete. To configure client systems, please follow 11.	
the instructions on the proceeding page.

A

B

C
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Installing an AnalyzeDirect.lic Floating License – Client System Configuration

Once the BIRlic license server is running on the server system, client systems can be configured. 
Complete the following steps to configure the client systems:

Install Analyze 9.0 on any client systems.1.	

Then, locate the 2.	 AnalyzeDirect.lic license file sent to you via e-mail. 

Save this 3.	 AnalyzeDirect.lic file in the C:\BIR\BIRlic-9.0\Licenses directory.  

Click 4.	 Yes when asked if you would like to replace the existing ‘AnalyzeDirect.lic’. 

No additional configuration is necessary on client systems.5.	  You should not start the BIRlic 
license server on the client systems. For more information on running Analyze 9.0, please refer to 
the section entitled “Running Analyze 9.0”.

If at any point you encounter difficulties getting your floating license server or client systems up and running, 
please contact support@analyzedirect.com.
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Once you have installed Analyze 9.0 and your AnalyzeDirect.lic license file, you are ready to run the program.

To open Analyze 9.0, select 1.	 Start > All Programs > Mayo Clinic Analyze > Analyze 9.0 or click on the 
Analyze 9.0 Desktop shortcut icon.

The first time Analyze 9.0 opens, the 2.	 End-User License 
Agreement for AnalyzeDirect Software will appear. Please 
read the agreement carefully and then click I Accept or Exit.  
Note, if you click ‘Exit’ Analyze 9.0 will not open.

Once you have accepted the End-User License Agreement, 3.	
Analyze 9.0 will open.

As with most software products, the process of bug fixing and 
minor maintenance between versions is an ongoing process. 
Analyze has all such fixes available in the form of a patch. 
Patches can be automatically downloaded and installed by 
selecting the Help > Analyze Update option from the main 
Analyze window. 

If it is detected that a new patch is available when you select Help 
> Analyze Update, a window will appear, asking if you wish to 
download the update. Click Yes to download and install the patch 
update.

It is recommended that you check for new patch updates the first 
time you run Analyze 9.0 and then once each month.

If Analyze 9.0 fails to open, please contact 
support@analyzedirect.com.
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All AnalyzeDirect.lic license files are encoded with an expiration date. For Analyze evaluators, this date 
is 30 days after the license file was first sent. If you are an evaluator and you still wish to use Analyze 
following the expiration of your license file, please contact sales@analyzedirect.com to find out about 
purchasing options.

For Analyze customers, long-term AnalyzeDirect.lic license files are provided in 12-month increments. This 
provides the opportunity for you to change the system on which Analyze is run. 

AnalyzeDirect contacts all customers one month prior to the expiration of the license file to determine if the 
license file system information is still current. Once AnalyzeDirect receives you confirmation of the system 
information, a renewal 12-month license file will be sent via e-mail. If your license file expires, and you have 
not yet received a new license file, please contact validate@analyzedirect.com to obtain your renewal 
license file.

Locate the new 1.	 AnalyzeDirect.lic license file sent to you via e-mail.

Save this 2.	 AnalyzeDirect.lic file to the C:\BIR\BIRlic-9.0\Licenses directory. A dialog box will be 
returned stating that the file ‘AnalyzeDirect.lic’ already exists, click Yes to replace it.

Analyze 9.0 should now be ready to use.3.	

To install a renewal AnalyzeDirect.lic floating license file, first do the following on the system acting as the 
license server:

Locate the new 1.	 AnalyzeDirect.lic license file sent to you via e-mail.

Save this 2.	 AnalyzeDirect.lic file to the C:\BIR\BIRlic-9.0\Licenses directory. A dialog box will be 
returned stating that the file ‘AnalyzeDirect.lic’ already exists, click Yes to replace it.

Open the 3.	 BIRlic Tool (Start > All Programs > Mayo Clinic Analyze > BIRlic Tool).

Select the 4.	 Server tab. 

First, click 5.	 Shutdown Server. Then, restart the server by clicking Start Server.

Next, do the following on all of the client systems: 

Save the new 1.	 AnalyzeDirect.lic file to the C:\BIR\BIRlic-9.0\Licenses directory. A dialog box will be 
returned stating that the file ‘AnalyzeDirect.lic’ already exists, click Yes to replace it.

No additional configuration is required on the client systems. Analyze should now be ready to use on 2.	
both the server and client systems.
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There are several excellent resources available to help you get started with Analyze 9.0. 

To quickly learn the basics of Analyze, we recommend that you work through the Analyze 9.0 Quick Start 
Guide – found on the silver Resources CD included with your software package. The Quick Start Guide 
contains a series of short exercises covering the most commonly used Analyze features and functions.

The Analyze Tutorials (optional component during installation) and the Analyze User’s Guide, both available 
from the Help menu in the main Analyze window, are another excellent resource, providing detailed 
information about the Analyze modules.

Analyze Viewlets (short tutorial movies) are also now available and can be accessed by selecting the 
Analyze Viewlets option from the Help menu. The viewlets show many of the key features and functionality 
of the Analyze modules and can help you become familiar with the program interface.

The tutorial data used in the Analyze 9.0 Quick Start Guide exercises and the Analyze Tutorials can be 
found on the silver Resources CD. To install the tutorial data from the Resources CD, do the following:

Insert the silver 1.	 Resources CD into your computer.

Open 2.	 Analyze 9.0.  From the main Analyze window select Help > Analyze Tutorials.

In the Tutorials window, click the3.	  Install Tutorial Data button.

In the window returned, specify the file path to the 4.	 TutorialData folder on the Resources CD 
(e.g. D:\TutorialData).

Click 5.	 Install. The tutorial data will be copied into the C:\BIR\images\TutorialData directory.

Please note - Analyze does not automatically configure all supported file formats. This keeps module startup 
time to a minimum, loading only those image formats that you need to use with Analyze for your purposes. 
To configure and load all supported file formats in Analyze, use the Import/Export module’s External 
Libraries tool.  Instructions on how to use the External Libraries tool can be found in the Quick Start Guide, 
Exercise 3: Switching on Support for Additional Formats.

For Analyze technical support issues, please contact the AnalyzeDirect Support Team at 
support@analyzedirect.com. For information about purchasing a Maintenance Agreement, which 
provides unlimited priority technical support, live online training and free version upgrades, please contact 
sales@analyzedirect.com.
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The Analyze Developers Add-On allows software developers to extend the capabilities of Analyze by 
developing their own macros and modules, using the AVW (A Visualization Workshop) image function 
library upon which Analyze is built.  The library is robust and includes over 600 imaging functions that can 
be called at a C-language level. 

Note – the Analyze Developers Add-On assumes you are familiar with programming.

To get access to AVW development capabilities, you must select the ‘Custom’ install during Analyze 9.0 
installation. The Developers Add-On also requires a special AnalyzeDirect.lic license file that will allows 
access to the AVW development capabilities. All 30-day evaluation license files provide access to the 
Developers Add-On.

If you already own an Analyze license and would like to evaluate the Developers Add-On, please contact 
sales@analyzedirect.com.

During the ‘Custom’ install of Analyze 9.0, the AVW Programmers Guide, AVW Reference Manual, and AVW 
Quick Reference Guide should have been installed in the C:\BIR\AVW-9.0\Manuals directory.  You can also 
find these documents under Start > All Programs > Mayo Clinic Analyze > AVW Developers Kit.

The best place to start practicing with the AVW functions is with the examples provided in the 
C:\BIR\AVW-9.0\Extras directory. This directory contains a number of example source files, both in C 
and in Tcl/Tk, for common Analyze imaging tasks (like rendering, segmentation, etc.). Note that while 
Analyze uses Tcl/Tk, the AVW library is interface-independent, allowing developers to work in almost any 
development environment.  If you do want to know more about Tcl programming, we recommend starting 
with the ‘Bible’ of Tcl/Tk - “Practical Programming in Tcl and Tk” by Brent Welch. This comes with a CD that 
you can load on to your computer, which includes a full Tcl/Tk implementation and many examples.

The .tcl scripts contained in the C:\BIR\AVW-9.0\Extras subdirectories are full source code scripts that can 
be run, however, you will need to setup the Tcl/Tk environment such that these scripts can find the Tcl/Tk 
files needed to execute. The develop_env.bat script included in the C:\BIR\AVW-9.0 directory provides an 
example of a script that can be used to set these development environment variables.
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The following instructions are for users who have purchased a dongle for their Windows node-locked 
license.

Please DO NOT attach the dongle to the system until directed to do so in the instructions below.

Install Analyze 9.0 according the instructions found in the section entitled “1.	 Installing Analyze 9.0 on 
Windows Systems”. 

Ensure that your dongle is 2.	 NOT attached to your system. The dongle driver must be installed before 
attaching the dongle to your computer.

The dongle driver installation program is shipped with Analyze 9.0. To find the program, navigate to the 3.	
following directory based on your version of Windows:

Windows XP or Vista (32-bit)•	  – C:\BIR\BIRlic-9.0\PC_NT\USB_Dongle
Windows XP x64 or Vista 64-bit •	 – C:\BIR\BIRlic-9.0\PC_NT64\USB_Dongle

Double-click on the 4.	 Install.exe found in your respective directory to begin the dongle driver installation.

In the Security Key Installation window that opens, 5.	
check the USB Dongle option. 

A dialog box will be returned asking that you do NOT 6.	
attach the dongle until the installation is completed. 
Click OK to dismiss this window.

Select 7.	 Standalone (if not already selected) and then 
click Begin Install.

Once the installation process is complete, a notification 8.	
will be returned, click Close to dismiss the window.

Attach the dongle to your computer’s USB port. In Windows XP, the Add Hardware Wizard will 9.	
automatically open; follow the instructions in the Wizard to complete driver installation. In Windows 
Vista, the Add Hardware Wizard will run silently in the background - no further steps are required.

Next, locate the 10.	 AnalyzeDirect.lic license file sent to you via e-mail.

Save this 11.	 AnalyzeDirect.lic file to the C:\BIR\BIRlic-9.0\Licenses directory. A dialog box will be 
returned stating that the file ‘AnalyzeDirect.lic’ already exists, click Yes to replace it.

Analyze 9.0 will now run when the dongle is attached to your computer. Repeat these installation steps 12.	
on every computer on which you plan to run Analyze 9.0 using the dongle-based license.

If you did attach your dongle before installing the driver, please remove it and follow steps 3 and 4 to open the 
dongle driver installation program.  However, instead of proceeding with step 5, select the ‘Uninstall’ option and 
click ‘Begin Uninstall’. Once uninstall is complete, repeat the steps above.
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